xshell5无法启动:要继续使用此程序,您必须应用最新的更新或使用新版本的解决办法

发布于 2019-01-03  2.08k 次阅读


xshell5无法启动:要继续使用此程序,您必须应用最新的更新或使用新版本的解决办法

使用的是xshell5最后一个版本,Build 1399
最近NetSarang强制更新,不更新直接不让用。
原因是软件加了时间判断过期,网上的方法大多是要修改时间到2018/12/25之前,当然解决办法除了修改时间,直接修改文件也可以。
hostloc的大神提供了详细的解决办法:

  • 找个反汇编软件(C32asm)
  • 打开nslicense.dll
  • 搜索16进制 7F0C81F98033E1010F8680
  • 修改为
  • 7F0C81F98033E101E98100 或 7F0C81F98033E1010F8380 都可以

附上已经修改好的文件 nslicense.dll ,直接在xshell安装目录里面替换即可
https://soft.gt.gs/Other/nslicense.dll


Flyfish's Blog - 飞鱼博客| 点滴记忆,记录成长---flyfish